+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Gothic-Supermoderator
    Ritter des 12. Kelches
    RoiDanton's Avatar
    Join Date
    Jan 2003
    Location
    Terra
    Posts
    11,212

    Gothic 3 Patch 1.75 release

    After a series of non-official patches for Gothic 3, we finally present another official patch version: CP 1.75. It can be installed over every Gothic 3 version, is available for each language and contains all previous patches.
    You have to start a new game after the installation. Old savegames are not compatible.

    There were several changes since the last official patch (CP 1.60): Besides countless major and minor bug fixes, graphics and performance improvements, the features “Alternative Balancing” and "new A.I." were introduced with CP 1.70.

    Compared to the previous patch (1.74), CP 1.75 offers widescreen support for the menus, new graphics options (like color grading and FXAA), and decreasing of stuttering by using a shader cache.

    In addition, the patch includes a ModKit, the Gothic 3 Genome Lite Edition. With that ModKot it's possible to change or create new game content in limited ways. There were also more possibilities for modders included in the game. The new features and the ModKit are explained in the respective modder manual and editor guide.

    Changes in that patch are listed in the changelog and further explained in the readme file.


    Advices for installation:
    Older Gothic 3 patches will be uninstalled automatically while installation. During that process, the backup of the file „ge3.ini“ will be deleted which was saved by previous community patches. Deletion is necessary because the patch makes important changes in the ini-files.

    During the installation, modifications in the installation folder could lead to problems. Therefore please uninstall all modfications before installing CP 1.75.

    Compatibilty:
    Savegames of the 1.75.12 Version (Gothic Complete Edition and Gothic 3: Gold Enhanced Edition) can be used. Savegames from older versions (1.74 and older) are not compatible.
    ini files of versions 1.74 or older are incompatible, too. Do not replace the ini files with older version because it could cause errors.

    Modifications which were released before CP 1.75 are incompatible (except they contain only texture changes). Look into the description of a modification whether it was adjusted to CP 1.75 before you install it.

    Modkit:
    The installer for the modkit is in the folder „ModKit“ in the Gothic 3 installation folder. A guide will also be installed for the ModKit.
    Advice for installation: It has to be installed in another folder than the Gothic 3 installation folder. Installing it in the G3 installation folder causes errors.

    Mirrors:
    Nordic Games
    Mad Vulture Games
    CD Projekt
    World of Gothic
    AtomicGamer
    GameFront
    gamershell
    Softpedia
    PlayerAttack
    ePlay
    ePrison

    Check sum: md5: D0722159170DEF9E78676B089F18F5E2

    Torrent
    Mad Vulture Games



    UPDATE for first version from 24.04.2012 until 25.04.2012

    For all of you who already downloaded the "old" patch 1.75 there is an update file so that you do not have download the whole patch again. Copy both files into the "Data" folder of your Gothic 3 installation.
    Update for 1.75.14 (from 24.04.2012 and 25.04.2012!!!)
    Update on World of Gothic --> file Gothic_3_EE_Patch_v1.75.14_update.rar




    Modder manual english
    Guide for the Genome Lite Edition (Editor)
    Changelog English
    Readme English
    Last edited by RoiDanton; 30-04-2012 at 21:40.

    Mondgesaenge: G1DB, G2DB (deutsch, english), G2ADB (deutsch, english ), G3DB, Marvin-DB

  2. #2
    Registered User
    Join Date
    Oct 2008
    Posts
    118
    Very good work - all but removes most stuttering.

    Not too sure what the "colour grading" option is meant to do. If makes it look like the game is being rendered on a Voodoo 2 or something.

    Unfortunately the crash under the Silden --> Geldern bridge (near the ranger camp) still happens (the video ends suddenly because that is where the game crashes and FRAPS only captures 3D).

    http://youtu.be/0euJ1IYY0fA

  3. #3
    Gothic-Supermoderator
    Ritter des 12. Kelches
    RoiDanton's Avatar
    Join Date
    Jan 2003
    Location
    Terra
    Posts
    11,212
    Quote Originally Posted by gstanford View Post
    Very good work - all but removes most stuttering.

    Not too sure what the "colour grading" option is meant to do. If makes it look like the game is being rendered on a Voodoo 2 or something.
    Thanks to you.

    Please take a look into the modder manual, chapter 1.8.2. There you can find the explanation about color grading.

    Quote Originally Posted by gstanford View Post
    Unfortunately the crash under the Silden --> Geldern bridge (near the ranger camp) still happens (the video ends suddenly because that is where the game crashes and FRAPS only captures 3D).
    Unfortunately this can not be fixed. We searched for the reason, together with Spellbound while we made the patch 1.60 and later. We never found any hint why there is that problem.

    Mondgesaenge: G1DB, G2DB (deutsch, english), G2ADB (deutsch, english ), G3DB, Marvin-DB

  4. #4
    Registered User
    Join Date
    Jul 2006
    Posts
    65
    This is rather off topic but I can't think of a better place I might get an answer. Does anyone know anything about getting Antialiasing to work? There are some settings you can apply using the NVIDIA Inspector that actually make it work using a compatibility flag but it makes all the reflective surfaces like water act funny. Random textures appear on them. I actually think it's worth it since AA makes the game look so much better, but fixing the water would be nice too.

  5. #5
    The Dark Lord Prokroustis's Avatar
    Join Date
    May 2006
    Location
    Greece
    Posts
    2,990

  6. #6
    Registered User -<Metroid>-'s Avatar
    Join Date
    Oct 2004
    Location
    Finland/Greece
    Age
    23
    Posts
    102
    I am speachless. You guys are still working hard making this already wonderfully patched game even better! I just want to thank you all for your great work. I've been really enjoying the previous patch. Keep up the great work!


    This calls for another playthrough! Yeah!

  7. #7
    Registered User
    Join Date
    Jul 2006
    Posts
    65
    This is really cool. A few months ago I decided to undergo my first attempt at creating mods for a game and discovered that perhaps G3 wasn't the best game to start with. I'm a professional software developer and am a pretty technical guy so I was able to eventually decipher some of the content of the binary template files (after using google translate to read all the German help on the subject ;-/ ) and started working on some tools to help edit them but nothing terribly sophisticated. I even started toying with the idea of creating a full editor. I'm glad there's a now a full blown editor for these files and I don't have to write one :-).

  8. #8
    Registered User krychu921_PL's Avatar
    Join Date
    May 2012
    Posts
    2

    Smile Hi

    Hi. Ok i send message on new thread.
    Bug with Keldron don't upset me. ( I'm very happy because this patch introduces a lot news and Gothic is my favourite game ). Thank you very much for patch

    My specification's:
    C2D e8400 (3.0 ghz)
    2x2 gb ram ddr2 800mhz goodram
    gainward gts 450 512/128 gddr5
    msi p35 neo2-fir
    Corsair CX 600W
    Windows Vista x86 Home Premium

    Error with device show me only 2 times (I reinstall game with patch and now him disappeared).
    My friend have problem with Gonzales (he don't have optional dialog to sell key him). He don't tell me anymore...
    Game with this patch 1.75 is fantastic, now I have zero bug's (today I reinstall game and maybe greatly helped?). Now I'm going to play Gothic3. Thank you for rapid help.
    Greetings krychu921_PL

  9. #9
    Registered User
    Join Date
    May 2012
    Posts
    1
    So if I were to freshly install Gothic 3 today, the 1.75 patch is the only patch I would need? Or are there other patches that need to be installed first?

  10. #10
    Gothic Super Moderator
    RPG Community
    Muetze's Avatar
    Join Date
    Jun 2007
    Location
    Auf'm Kopf
    Posts
    4,908
    Quote Originally Posted by joemamasan View Post
    So if I were to freshly install Gothic 3 today, the 1.75 patch is the only patch I would need? Or are there other patches that need to be installed first?
    You only need CP1.75, right.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts